Требования к аппаратному и программному обеспечению для установки и работы с системой дистанционного обучения на основе ПО joomla.

Поначалу Moodle создавался в Linux с использованием Apache, MySQL and PHP (Linux + Apache + MySQL + PHP = LAMP), но регулярно проверялся в работе в среде Windows XP/2000/2003 (WAMP), Solaris 10 (Sparc and x64), Mac OS X и Netware 6. Также имеется поддержка СУБД PostgreSQL, Oracle и Microsoft SQL Server.

Замечание о хостинге: В России не так уж много хостингов удовлетворяет требованиям к системе, предъявляемым Moodle. Вам необходимо связаться со службой поддержки соответствующей организации до подписания соглашений с ними. Особое внимание необходимо уделить ограничениям PHP (memory_limit) и MySQL. Если же веб-хостинг не обладает нижеперечисленными возможностями, необходимо выяснить почему, и, по возможности, отказаться от их услуг.

Для работы Moodle предъявляет следующие требования к системе:

Оборудование

  • Место на диске: на диске должны быть свободными минимум 160 МБайт. Кроме того потребуется больше свободного места, для хранения Ваших учебных материалов.
  • Оперативная память: минимальный объём - 256 МБайт, рекомендуемый - 1 ГБайт. Вы можете руководствоваться следующим правилом для приблизительного вычисления необходимого Вам объема памяти: 50 одновременно работающих в системе пользователей на каждый 1 Гб памяти. Обратите внимание, что эта цифра может быть неточной и зависит от комбинации используемого вами оборудования и программного обеспечения.
    • Это определяется ограничениями услуг хостинга PHP и MySQL.
    • Количество пользователей, которые смогут пользоваться Moodle может быть ограничено производительностью сервера. Смотрите про производительность сервера

Программное обеспечение

  • Веб-сервер. Большинство предпочитают веб-сервер Apache, но Moodle будет хорошо работать и с любым другим веб-сервером, который поддерживает PHP, например IIS под Windows. PHP не предъявляет требования к версии веб-сервера, но тем не менее (общий совет) - используйте, по возможности, самую новую, из стабильных, версию веб-сервера.
  • Язык сценариев PHP (обратите внимание, что есть особенности установки Moodle с PHP-Accelerator). На данный момент существует 2 основные версии (ветки) PHP: PHP4 и PHP5. Ознакомьтесь с требованиями к php
    • версия 4.3.0 и выше для Moodle 1.9
    • версия 5.2.8 и выше для Moodle 2.0
  • Работающий сервер баз данных: Полностью поддерживаются и совместимы с Moodle следующие серверы баз данных:
    • MySQL (Внимание! Опция "strict mode" в MySQL должна быть отключена)
      • версия 4.1.16 и выше для Moodle 1.9
      • версия 5.0.25 и выше для Moodle 2.0
    • PostgreSQL
      • версия 8.0 и выше для Moodle 1.9
      • версия 8.3 и выше для Moodle 2.0
    • Microsoft SQL Server
      • версия 9.0 и выше для Moodle 1.9
      • версия 2005 и выше для Moodle 2.0
    • Oracle
      • версия 9.0 и выше для Moodle 1.9
      • версия 10.2 и выше для Moodle 2.0
MySQL подойдет для в большинстве случаев, потому что она очень популярна
Последнее изменение: Thursday, 18 August 2011, 21:22